IB and java


Well-known member
I wanted to try demo on IB and for that I had to download Java but since than every thing is so slow on my computer. I had to give up and uninstall java. Things are now working as normal. Any help what I can do to overcome the problem? Any help will be much appreciated . Thanks in advance :eek:


Active member
that happened to me too! had to download some sort of java console thing on my PC and subsequent to that it went about as fast as a central line train.....

I'm no help but would also be interested to know why?


What spec of PC are you running and what operating system ie
Pentium 4,
CPU 1100Mhz,
256MB of Ram
Windows XP Operating system



Legendary member
Similar here too, but with FinSpreads. I had to delete some Java thing and then it loaded ok. I phoned their tech support and they said it must be something to do with my ISP. Yeah! Right!
One thing I have noticed with my XP Pro system running office 97.... now and again, for no reason, it has a "go slow" on me. Ctrl alt del shows that winword is running consuming 98% resourses!I haven't even opened word....... ending the task solves the problem. Again, no idea what that's all about :(


Well-known member
Dear Trader333

It is a laptope with Win 98 and memory 64 and probably 700 mhz. Laptop is Compaq presario 1200 series. Any help much appreciated as I would like to try the demo from IB to learn about futures. Thanks


Active member
I had the same problem too.
Once I had downloaded the Java console , Finspreads and Cityindex applets wouldnt work. In fact IE would close itself down when in cityindex( perhaps IE is cleverer than we thought!?!?!)

The only way around it I have found is to go to :
Internet Options
and then remove the tick from the Sun - Use Java box ( u will have to reboot)

Cityindex and Finspreads now work fine.

I have now downloaded IB onto my desktop , then u do not have to access it via IE.


Legendary member
Ditto here. I subscribe to Prophet.net and tonight it took me a good 5 min's to log on to their homepage. After 10 min's I gave up trying to open JavaCharts. All of which is a bit of a ****** really, as it's the prospect of trading the 7-9 U.S. session that keeps me motivated throughout the day! Not a happy bunny :-( So, I'll add my cry for help to those above - HELP!

AMD AthlonXP 1600
40 GB Hard Disc
56kbps Modem
Windows Xp Home Edition
ISP - Freeserve (who cut me off at least once every 1.5 - 2 hours!)

Any advice, much appreciated. Thanx in advance.


This issue is all caused by Microsoft not wanting to give any opportunity to their competitors. Anyway when I downloaded the latest version of Java it just wouldnt work so I reverted to version 1.4.0_03 and this was better but still gave me problems so try the following:

Go to Control Panel and locate this Icon which is the Java application control panel.

Once located open it and select "Browser" now untick any ticked options in the list.

Close everything down and just to be sure re-boot your PC. Check again that the option is unticked. This worked for me and hopefully will do for some of you as well.

Good Luck



  • java.jpg
    2.8 KB · Views: 957


Junior member
I've had quite a few probs with the Sun Java VM. Basically its a big pile of poo. You need to have Microsofts Java VM installed but due to some major security issues MS have taken it off their 'windows update' website. Fortunately there are still loads of other websites that have the file. Once you've downloaded and installed it pop over to the windows update website and download the security patches for it.




Senior member
You need Microsoft Java VM for the web based Deal4Free. Paul has shown you how to enable the MS Java VM by simply disabling the Sun Java from Browser integration.

The MM software from Deal4Free uses the Sun Java...

Microsoft VM is available via XP Service Pack 1 for XP users.

AdBlock Detected

We get it, advertisements are annoying!

But it's thanks to our sponsors that access to Trade2Win remains free for all. By viewing our ads you help us pay our bills, so please support the site and disable your AdBlocker.

I've Disabled AdBlock    No Thanks