Help needed re IB TWS

Grey1

Senior member
Messages
2,190
Likes
201
Help needed

For some reason my IB screen has slowed down hugely .. I looked at the processor in the task manager and it seems to be running at 100 % all the time .. I have never had this problem before ( I have 2 * 512 RAM ..) .. I used to have my data through Alcatel using USB but recently updated it to Actiontec Gateway (to have wire less connection to my lap top too..) which uses the 3COMethernet controller
I have installed the IB on the lap top and works fine ..
I have re- installed IB and JAVA to make sure I have not deleted any files by mistake with no effects..

So what could be the problem ?

thanks
 
Look and see in task manager what process is consuming all your resources...... I have a problem where winword stays "open" yet there is nothin on the screen to say it's open. Task manager shows it as running and taking 98% resources. I then delete it and all is back to normal. This is on XP.
 
Thanks, I will try it when the market is open 2morrow as the problems starts once data fills in ..
 
Just a thought, is Excel running???? I guess you're running win2k or XP. Win 98 will throw up with >512Mb ram.
 
I do not run EXCEL any more but have other scanners at the back ground .. I have never had this problem before as I said , The lap top with lower spec runs fine .. Also I use Win2000 pro..
Could it be any thing to do with my ethernet card no coping with broad band ?

iraj
 
I don't have this problem myself, but have heard of it. One of the possible problems is that the DirectX system isn't compatible with your video drivers. The best solution is to get different drivers (good luck!), but you can turn directx off for tws by adding "-Dsun.java2d.noddraw=true" into the command line. To do this, edit the properties of the shortcut you use to run tws. The target will read something like: ""C:\Program Files\Java\j2re1.4.1_02\bin\javaw.exe" -jar D:\Jts\jts.jar D:\Jts" Change this to: "C:\Program Files\Java\j2re1.4.1_02\bin\javaw.exe" -Dsun.java2d.noddraw=true -jar D:\Jts\jts.jar D:\Jts

Of course, all that assumes that the video drivers at fault. From what you've said, it is more likely the network drivers are messed up. You should also make sure that the drivers for the old network card are properly removed/disabled (control panel-> system-> hardware-> device manager for that).

Steve
 
Iraj??????
Try a new network card. There is absolutely no problem with a network card not being able to cope with broadband. It's throttled back to 10Mbits/sec. Duff network cards are quite common in clogging networks.£10 buys a new one.
 
Chartman
is there a fix for the Winword bug other than deleting? I get the same thing happening even though I have re-installed Word. It also happens when I switch to another virtual matrox desktop.
 
CHARTMAN,

The problem was with Direct x..

This is the email I got from IB which sorted out the problem..

Thanks for the help any way ..

Quote "
There is a string you can add to the trader workstation shortcut that will disable direct draw that may help.
To add this do the following: from your desktop right mouse click once on the trader workstation icon, click on properties, go to the shortcut tab at the top, in the target field you should see something like this depending on your version of java:

"C:\Program Files\Java\j2re1.4.1_03\bin\javaw.exe" -Dsun.java2d.noddraw=true -jar C:\JTS\jts.jar C:\JTS

Add this string: -Dsun.java2d.noddraw=true

Altogether it will look like this: "C:\Program Files\Java\j2re1.4.1_03\bin\javaw.exe" -Dsun.java2d.noddraw=true -jar C:\JTS\jts.jar C:\JTS

If you aren't using java 1.4.1_03 just replace that part in the string to the version you are using.

After that hit okay and try loading up tws again.
 
Top