argh MM5 and xp pro


Active member
hi all hope you can help as D4F cant. i recently opened an account with them and received their install cd through the post. however I cannot connect to their servers. Whenever I try I receive the message 'Logon failed because cannot connect'. Obviously this is becoming very annoying. At D4F suggestion I have downloaded the latest java and disabled my firewall to no effect. I am with freeserve on ADSL with a Copperjet modem. I do not believe that I use a proxy server as this option is not ticked in internet options. Their suggestion that it is simply due to busy servers is unsatisfactory. Please help me get trading :devilish:

This is probably not very helpful, but I have XP pro and I can
use MM5 OK. I did have to install the Java first tho.

I am on BTOpenworld.

Sorry same as ImranQ, no problems. I doubt very much if it's a firewall issue.
I do not think it is an xp problem.... I get this message every now and again, deleting one or two files from MMv5 normally sorts this out for me and I can log on as normal. D4F dont seem to know why this happens but it is a real pain.

Locate the MM software folder in My computer, the folder you are looking for is MMv5 locate the "cfile" and delete. re-launch program and hey presto.

This is there usual response to any problem of any nature if this doesnt work then its reinstall time am afraid.
sounds to me as though little has changed at D4F, perhaps you should move on to another company.

I have no connection with a SB company other than a client of IG INDEX
well this is fast becoming ridiculous. I will DL their lite version but if that doesnt work I can't see any other alternative and D4F will have lost a customer. I have absolutely no trouble connecting to any other site/program/server. Quite absurd and very annoying.
Suggy did you have the trial version first? i.e. the dummy client.

If you did you need to uninstall it and remove all files including registry (internet and system) files. This happen to me when I first tried to connect. I will try to find the page where I found the solution.

Hope this helps.
Suggy, Oops :eek:


could it be a be a conflict with Direct X? Sorry to sound a little vague on this subject, but seem to remember way back having a similar trouble & it was down to the above conflicting with the Java C- I think- from memory needs turning off.

Hope this helps,

Cheers Ls
Last edited:
JE2000 said:
Suggy did you have the trial version first? i.e. the dummy client.

If you did you need to uninstall it and remove all files including registry (internet and system) files. This happen to me when I first tried to connect. I will try to find the page where I found the solution.

Hope this helps.

Little confused now as I have only installed the MM from the cd but it comes up as dummy client. Is this correct?

Smudgy, any advice as to how to turn directx off would be appreciated.



Half asleep this am, hence the wrong name,

Slept a lot since I had the problem, :D

Best bet is to ring D4f tech line and see if that could be the problem
it only takes a few seconds to switch it off, they will be able to direct you better than I could do from here.

Hi suggy

I get this problem if there is insufficient band width during log on. Make sure you aren't downloading anything else at the same time it needs at least 30kbps to itself to start up, afterwards it is less fussy.

cheers pete
no bandwidth would not be an issue. Ill give them a ring about directx. thanks all.
suggy do you get the MM5 interface appearing? The other
thing to check is that when you fire up MM5 you may have
noticed a teacup type icon appearing in the bottom right
corner. Ricght click it with your mouse and click on the log option.
Check if there is any dodgy message in the log.

Also check the web browser interface to CMC. Check if
that works.

well its quite annoying. When using the MM5 shortcut on my computer I get their logon screen, I can enter details but it can't connect.

But when I go to their 'live logon' screen on the website I get a little teacup where the logon screen would be and a load of java messages in the toolbar at the bottom. I think it ends with something like 'java appletfail init' which I take to mean basically java is failing to load. Then I just get a red cross in the area for logon. But it works fine with all other java programs and I have the latest version installed. Basically the only problem is with this program/website. But I'm stumped as to why . . . its costing me hair!
have you tried my suggestion from above.... it sounds like a problem I have had and deleting the appropriate file resolved the issue for me.
Failing that it sound like you need the latest update for your java which you can get from their web site.
ok thanks for all suggestions. Unfortunately none of them have worked ;)

I have java 1.4.2 installed.
The cd I was sent installed the 'Dummy Client' onto my computer is this correct?
I am using zonealarm as a firewall with medium settings, although MM never seems to ask for internet access.

Deleting that file just means I have to download it again with no change. I don't think its a firewall issue as nothing changes even when I have completely disabled it.

I take it that you are trying to go 'live trading' on CMC. Dummy Client will not let you do this. For what ever reason, it is different. For live trading go to this site and download it. Make sure that you install to a different directory to the one dummy client is in. I suggest, when it asks if you want to install it to 'programfiles/marketmaker/spreadbetclient', you change it to programfiles/mmaker/spreadbetclient. By doing this, windows will be able to differentiate between one and the other.

Hope this helps.
just thought I'd let people know that the problem was down to D4F sending me the wrong cd. Oh well, c'est la vie . . .
Good luck with them :cheesy:

Some advice if i may, DONT take cmc's word for anything if you think your right then you probably are.

If you are unsure about something, say an order execution, take a screen shot so you have evidence for when you argue your point. :devilish:

I have had several issues over my time with them and they will deny it till there blue in the face but as soon as you say "ive got a screen shot telling me different" they will oblige. ;)

HTH :cheesy: