Accessing IB or D4F through Corporate firewall

X-Ray Specs

Junior member
I've been trying (unsuccessfully) to access my D4F and IB accounts through a corporate firewall.
I think the problem lies in the fact that they both try to connect directly using socket 7496.
The error log for IB is below.
Tunnelling software to a webserver is also a no no.

Any suggestions gratefully received.

10:26:57 JTS-Applet: The file c:\IBJts\jts.ini does not exist
10:26:59 JTS-Applet: Started on 7/9 at 10:26
10:26:59 JTS-Applet: Build 797.4, 2003/06/13 10:50
10:26:59 JTS-Applet: applet = true
10:26:59 JTS-Applet: host =
10:26:59 JTS-Applet: remotePort = 4000
10:26:59 JTS-Applet: localPort = 0
10:27:08 AWT-EventQueue-9: username = xxxxxxxx
10:27:08 AWT-EventQueue-9: Setting dir is c:\IBJts\
10:27:08 AWT-EventQueue-9: Connecting
10:27:08 JTS-Login: Creating socket
10:27:30 JTS-Login: Creating socket failed - Connection timed out: connect
10:27:31 JTS-Login: Creating socket
10:27:40 JTS-Dispatcher: Thread interrupted while waiting on Socket data buffer
Have you downloaded and installed the IB software to the pc you are trying to access it from ?

If not do that first and try again.

I've tried running IB from the downloaded software and also via the web browser.
Both return the same result.
I assume you have the appropriate Java software to run IB loaded onto your pc ? Are you able to get the firewall to allow trusted sites and IP addresses ?

I have the latest Java software loaded.
I am also able to browse the IB website and D4F.

I don't think I'll be able to run it from my desktop so was hoping for any info on remote desktop applications and their suitability
I have just downloaded the latest standalone TWS using the latest jave link from IB's download site.
The build version is '798.4' which is the latest version but my workstation has only 2 tabs above 'rapid order entry', when I was using the demo version it had more tabs showing 'futures' etc.
I think I must have the older version, can anybody using IB TWS confirm this for me.

I have been in contact with IB tech help but no luck so far.

Hi Boy

You only get 2 tabs by default. To add another one goto Page -> New and take it from there.


Sorry X-Ray, I can't help you with your problem :(
Thanks ftse beater, you de man, the whole of the IB tech dept has been informed.

Hi XRay,

If you want to do this then you will be bypassing your
company's IT rules. Just bear this in mind. With that
out of the way it is possible. The basic method you
use is tunnelling. There are two ways:
1) Use a payable service. Costs a few quid per month.
Look at
2) Buy your own proxy server to run on your
own PC. Costs about 30-40 dollars permanent license.
This is a worthwhile option if your ISP uses DHCP.
Look at

After you have setup for one of the above services you
will need to configure to remap and send all socket
commands for a particular SW you want to use to your
proxy server. You need an application called Sockscap (free)

Read the docs that come with the SW described above.


Some clarifications:

The reason why you cant use the SW in your company is
that your company is using a firewall and has blocked
certain TC/IP ports.

You run the http-tunnel sw on the PC that you want to run
the trading SW.

For the loopholesw, you run a server on your PC at home
and the client on the machine at work. Basically the client
redirects all connections to your PC at home. YOur PC at home
passes the actual commands on to the site. The data comes
back to your PC at home and is then redirected back to your
PC at work.
Thought I'd mention that if you dont want to do this then you will
have to use a remote desktop SW like PC anywhere and run
your trading SW at home.
Re: Accessing IB through HUAWEI EchoLife HG520i firewall

Accessing IB through HUAWEI EchoLife HG520i :mad:

if i access to IB TWS through pc and modem no problem but why I dint access through HUAWEI EchoLife HG520i :mad:

Login in progress (attempt 50) :confused:
Sorry the problem was not in the firewall settings on the modem, but in setting Comodo firewall. :|
Unfortunately I do not know exactly where. :mad: