XP Pro Broadband problems

hampy

Well-known member
276 5
Hi all, help required please.
Went broadband recently but my internet connection still auto disconnects after 20 mins of inactivity, despite having set the idle time disconnect in internet options to never. I have checked that device manager is not disconnecting to save power and am completely up to date with Windows and BIOS updates.
I suspect that the fault lies with the registry not accepting my changes to internet options. Have looked in reg edit but I'm now at the limit of my knowledge and there's no obvious answer there or from XP Pro help.
I'd appreciate it if anyone has any ideas
cheers ,
hampy
 

zambuck

Experienced member
1,608 102
Hi..hopefully following may resolve the issue...

Click Start > Connect To > Show All Connections...

Select your Broadband account icon

Right Click > Properties

Click Options and under 'Idle time before hanging up' choose 'never'

All the best
 

ChartMan

Legendary member
5,580 46
Make sure the " hang up after sending and receiving" box is not ticked........ in outlook express/tools/options/connection...
Is your BroadBand connected via USB? NOT an optimum solution and could be a problem. Far better to connect via 10/100 LAN...
 

Attachments

  • image1.gif
    image1.gif
    39.1 KB · Views: 536

hampy

Well-known member
276 5
Thanks folks , but already tried those without success.
Connection is via USB modem but will be via wireless router in 1-2 months.
I have already had problems with the registry on this machine refusing to accept changes which is what makes me think the solution lies there, but locating it in reg edit is beyond me!
Thanks,
hampy
 

Rognvald

Established member
916 15
You are using XP. Have you tried System Restore to a time before you went onto broadband followed by reinstalling your broadband kit
I have used usb to connect my adsl along with a usb adsl router and have occasionally experienced difficulties with the modem switching itself off after the whole lot is powered up (router not left on 24/7. A reboot takes care of this however
 

hampy

Well-known member
276 5
Thx, Unfortunately the problem has existed since I bought the machine a few months ago, but always accepted the problem with the view that I just had a poor dial up connection. Only since broadband arrived did I realise that the problem lay within XP
hampy
 

Rognvald

Established member
916 15
Have you an XP pro disk - you could reinstall but this is likely to cause much grief as you will almost certainly lose something precious to you unless you are v thorough with backups etc and imo is a last resort
 

anley

Senior member
2,730 229
Here's a workable solution that sounds complicated but is easy to set up and run.

Download the Pegasus Email program, it's free.

Set up another email address with your broadband supplier (I assume that you can have 10-20 email addresses etc).

Make sure this email is a stupid phrase like [email protected]

Load Pegasus email up for the new email address.

Set Pegasus to automatically check for email every 5 mins.

Pegasus can run from your Start Taskbar so in effect you'll never know it's running and the auto check keeps the internet connection alive.

Make sure you never give the email address out to anyone. You don't want this email address picking up mail.

Sounds crazy? Well it works very well.
 

DaveJB

Experienced member
1,159 42
Hi,
perhaps a stupid suggestion, but make sure you've done a darn good Antivirus scan and have a decent firewall installed... if your registry doesn't accept changes then XP Pro (which I use) isn't working right, and the biggest cause of that in 2003 has been viruses and worms. (With ADSL you want both installed and on, full time).
I don't think you need to hack the registry - if the problem isn't fixed pretty quick I'd suggest (much against my religion) taking the PC to your nearest PC World and telling them to fix it for you. (If they aren't as helpful as the adverts make out then express your disappointment at each step in a loud and clear voice, eg "Oh, right, your diagnostic service can only fix your own mistakes then?" - this often works quite well in the big chain stores).
An alternative is to create a system restore point, then look in Control panel, remove all Modems, look into the "My Network Places" and "View Network Connections" and remove all modem related connections, also remove all connections under 'Dial Up Networking'.
This is pretty drastic, you might like to try the DUN wipe on its own first - the restore point will let you return to 'pre-kamikaze' settings if it all goes horribly wrong.
Then power off, reboot, and reinstall your new modem .... assuming the problem might well be a 'legacy' setting to disconnect after 20 mins, then by killing all the DUN stuff (especially) you're in with a chance of deleting the setting as part of the clear out - the power off helps avoid Windows 'forgetting' to delete things you told it to ;)
Having run via a USB modem (Freeserve supplied garbage) I've since changed to a D-Link ethernet modem feeding a D-link ethernet Wifi router, and last time I looked only the toaster was having problems downloading - it's a minefield I'm afraid, sometimes the only recourse is to go back to the place you bought it all and say (loud voice time again) 'this is pants, I want my money back you thieving scum'.
Dave
 

esiotrot

Active member
157 0
Hampy
you wouldn't by anychance using BTOpenworld and their ADSL modem?

When I switched to broadband with BT they supplied a flat green Alcatel modem. I had the same problems as you have described. I believe that there are different firmware versions with this modem and BT kindly supply a "cut down" version which cuts off the connection. There is a "Professional" version of the firmware which does not do this. Check out the web for information, I cannot remember offhand where I found this.

When I switched to a router (Netgear DG814) this problem disappeared.
 

ChartMan

Legendary member
5,580 46
Anley et al., you can set outlook express to read mail once a minute. same effect, no effort. No need for pegasus. Just thought I'd mention it.
 

anley

Senior member
2,730 229
Chartman, yes you can set Outlook to check for mail every minute or so but you can't get that program to run from the Taskbar, therefore it is always in the way.

If you use Pegasus then you never know it's running in the background.
 

esiotrot

Active member
157 0
Sorry Dave
Perhaps my post mislead you; the firmware I'm talking about is loaded on the modem not a driver on the PC. I believe it's not easy to update the modem but it can be done - but not by me!!
 
 
AdBlock Detected

We get it, advertisements are annoying!

But it's thanks to our sponsors that access to Trade2Win remains free for all. By viewing our ads you help us pay our bills, so please support the site and disable your AdBlocker.

I've Disabled AdBlock